Megjelent a Technorati Rank WordPress bővítmény 2. verziója!

Forró az első Technorati Rank beépülő modul sarkában, a kimeneti tartalmat átalakítottam CSS hajtott (az alábbiakban egy képernyőképet használhat, amely a webhelyem oldalsávjában található):

Technorati Rank WordPress bővítmény 2. verzió

Ez az előállítás meglehetősen nagy kihívást jelentett, de a kimenet sokkal szebb. Először azt hasznosítottam, amin tanultam Bittbox hogy az Illustrator minden képkimeneti gombját elkészítse.

A következő lépés a stílusok felhasználása volt annak létrehozására, aki valakit létrehozott képtérkép kivéve, hogy valóban van nincs térkép! Igazából nagyon klassz. Beállíthatja a teljes div hátteret, majd az abszolút pozicionálást és a CSS-t felhasználva létrehozhatja az egyes „hotspotokat”. Tekintse meg a kimeneti CSS-t.

Hozzáadtam egy linket a Technorati újjához is WTF oldal és a webhely RSS címe. Remélem, tetszik ez! Szerintem ez hatalmas előrelépés az első verzióhoz képest! Van egy i link a jobb alsó sarokban, amely a plugint is népszerűsíti.

A Technorati Rank WordPress bővítmény 2.0.4-es verziója

23 Comments

  1. 1
    • 2

      Az biztosan! Már jó ideje kerestem az Illustrator segítségét. Nem használom eléggé ahhoz, hogy fantasztikus legyek benne, ezért egy olyan oldal, mint a Bittbox, SOK időt takarít meg nekem!

  2. 3

    Megpróbáltam telepíteni a legújabbat és a legjobbakat, követve az Ön utasításait a „betűig” 🙂

    de a következő hibát kaptam

    Végzetes hiba: Nem lehet nem létező osztályt példányosítani: simplexmlelement a /home/winex4/public_html/wp-content/plugins/technorati-rank/technorati-rank.php fájlban a 64. soron

    valami javaslat?

    • 4
      • 5

        ez megtanít először ellenőrizni. A Lunarpages a PHP 4.4.4-es verzióját futtatja

        Kitalálom, hogy meg kell néznem a másik verziót, vagy keményen felakasztom, és megnézhetem, frissítenek-e 5.0-ra

        • 6

          Remélem, hogy megteszik! De remélem, hogy a gazdája is frissül. A PHP5 valóban sokkal jobb teljesítménybeli fejlesztéseket hoz, valamint néhány jobb eszközt az API-k fogyasztásához. A Jumpline-t használom, a kezdőlapomon egy link jelenik meg a szponzorlistámon. Azt is hiszem, hogy a Dotsternek van néhány jó VDS-tárhelye a legfrissebbekkel és a legfrissebbekkel.

      • 7

        Doug,
        Nekem ugyanaz a problémám
        Felhívtam a gépemet, és azt mondták, hogy a szerverem rendelkezik PHP 4 és PHP 5 programokkal, de ha egy fájlt szeretnék futtatni a PHP 5 használatával, akkor a parancsfájlnak .php5 fájlkiterjesztéssel kell rendelkeznie.

        Tehát ... Megváltoztattam a fájlkiterjesztéseket, és eltűnik a WordPress beépülő moduljaiból.

        Valami ötleted?

  3. 10

    Félelmetes bővítmény, kiváló stílus! Köszönöm Doug, és nagyszerű munkát. Soha nem is tudtam az elsőről, de ez az oldalsávomon megy.

    TÉNYLEG díjazó látni, hogy az Illustrator tippjeim segítettek a gombok elkészítésében !!!!!

    köszönöm mégegyszer,

    ~ BittBox

    • 11

      Köszönöm, BittBox! Azt hiszem, jó szemem van a stílushoz, de úgy tűnik, soha többé nem értem jól. A különbség abban rejlik, hogy ténylegesen le tudja tölteni a mintáit és boncolni őket. Most már ténylegesen megvalósíthatom ezeket az ötleteket. 🙂

      Ezután néhány gondolattal játszom a blogom fejlécével és hátterével kapcsolatban.

  4. 12

    Nos, Doug, úgy tűnik, hogy a 2-es verzió plugin utál engem. Hibaüzeneteket kapok:

    Warning: fopen(/technorati-rank.html) [function.fopen]: failed to open stream: Permission denied in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 121
    Warning: fwrite(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 122
    Warning: fclose(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 123

    A hibaüzenetek ellenére a Technorati rangomat is mutatja (~ 26.5k: D). Nem vagyok elég hozzáértő a PHP-hez ahhoz, hogy tudjam, miért sír az egyetlen fájl miatt.
    Elég érdekes, hogy a szerverünkön a SuPHP-t használjuk, így minden úgy fut, ahogy mi (így a chmod követelményei már nem igénylik a világon írható fájlokat, és a php szkriptek akkor sem hajtódnak végre, ha a chmod például túl magasan van).

    Ennek az aldomainnek az összes php-je php5-ként fut.

    Valami ötlet?

    • 13

      Van wp-content / cache könyvtár Xial? Úgy gondoltam, hogy jó lenne ugyanazt a gyorsítótár-könyvtárat használni, mint a WP-Cache-t. Utólag talán nem volt jó ötlet! Ennek a sornak mindenképpen a gyorsítótár fájlba kell írni.

      • 14

        Természetesen igen, Doug. Jó ideje futtatom a WP-Cache fájlt. 🙂

        Kicsit kíváncsi voltam arra is, hogy miért panaszkodik erre, mivel megvan a szükséges könyvtár, de feltételezem, hogy valami egészen másról van szó.

      • 15

        Érdekes információk hozzáadása:

        $ pwd
        /..../wp-content/cache
        $ ls -l tech*
        -rw-r--r-- 1 meeeeeeee meeeeeeee 1.1K Mar 12 11:47 technorati-rank.html

        Még mindig visszaadja a hibákat.

    • 16

      Csak azt akarja, hogy ugyanaz a hiba legyen. A webhelyen fut a php5, és a gomb megjelenik.
      Megpróbáltam megjegyezni a 121–123. Sorokat, és a dugó jól működik. Életbe tudom hozni, vagy hosszabb távon gondot okoz e vonalak hiánya?

  5. 17

    Ugyanazokat a hibákat kapom, mint fent, azt is gondoltam, hogy ez a cache dir, de van egy, és arról is gondoskodtam, hogy az írási jogok helyesek legyenek.
    Az oldalsávon megmutatja a plugint (rangsorban), de a fenti hibákkal.

    • 18

      Hi Richard,

      Ellenőrizheti, hogy rendelkezik-e a PHP 5+ verzióval és a CURL engedélyezve van-e? Ezt úgy teheti meg, hogy a webhelyével létrehoz egy oldalt <?php phpinfo(); ?> egy oldalon. Ezután nyissa meg azt az oldalt. Az oldal tetején lesz a PHP verziója, és kereshet a CURL kifejezésre annak biztosításához.

      Köszönjük!
      Doug

      • 19

        Nos, Doug, még egyszer ellenőriztem a PHP verziómat.
        Futtatom a PHP5-öt, és a cURL össze van fordítva (a szokásos három kérésem egyike a gazdagépemhez, hogy a dolgokat PHP-be fordítsam).

        Minden más rendben működik, de nem vagyok teljesen biztos abban, hogy miért fullad ez a plugin, hacsak nem a cURL PHP-be fordított verziója (7.15.4-nél tartunk, a legújabb pedig 7.16.1-nek tűnik). Viszont nem akarom a gazdámat arra kényszeríteni, hogy a php5-öt csak ezért fordítsa újra, ha tudok segíteni. <: 3

        • 20

          Mélyebben megnézem a hétvégén. Néhány webhelyen problémamentesen fut - tehát ez a 3 dolog egyike: 1. Gyorsítótár, 2. cURL vagy 3. PHP verzió.

          Kihasználhatom a régebbi PHP 4 funkciókat az XML behúzására és elemzésére, de ez meglehetősen lelassíthatja - ezen a hétvégén tesztelni fogok. Nagyra értékelem az összes hozzájárulást. "Houston van egy kis problémánk!".

  6. 21

    Csak egy megjegyzés: a Technorati elindított egy Hatóság Csatlakoztat.

    Továbbá - mindazok számára, akiknek problémái vannak ezzel a bővítménnyel, nagyon bátorítanám Önt, hogy költözzön egy új gazdagépre :) Van egy 12 hónapos ingyenes akcióm a házigazdámmal az alján Rólunk cimre.

  7. 22
  8. 23

    Jó néhány kérést kaptam arról, hogy hibák történtek a gyorsítótárfájl írásakor vagy olvasásakor. Valójában azonosítottam egy olyan problémát, ahol a gyorsítótár fájlt a gyökérkönyvtárba húztam és húztam. Módosítottam a 2.0.4 verziót úgy, hogy az a plugin könyvtárában lévő gyorsítótár alkönyvtárba írjon.

    Kérem, tudassa velem, hogy működik! (Még mindig szüksége van a SimpleXML-re és a curl-re!)

Mit gondolsz?

Ez az oldal Akismet-et használ a levélszemét csökkentése érdekében. Ismerje meg, hogyan dolgozik a megjegyzésed.